inSync Client 6.1.0
inSync Client 6.1.0 requires an account on inSync Cloud. Please contact your IT administrator if you have any questions.
The Druva inSync Client 6.1.0 -
  • is applicable only for Windows and Mac.
  • is NOT applicable for Private Cloud and On-Premise.
  • For latest inSync clients for Ubuntu, Cent OS and inSync mobile app, please visit this page.
    Desktop Application